Realtek firmware on Debian 10 Buster

Linux Kernel, Network, and Services configuration.
Post Reply
Posts: 1
Joined: 2023-09-18 08:19

Realtek firmware on Debian 10 Buster

#1 Post by igle »

Hello everyone,

I'm a little desperate with my ethernet network card with realtek chipset.

I have a Lenovo ThinkCenter M72e on which I had the network controller for my Unifi devices installed.
The controller stopped receiving traffic during the night and I began to investigate the problem. Everything seemed related to the firmware of the r8168 network card, which was only officially supported up to a Kernel lower than the one I had installed, so I decided to downgrade all system to version 10 of Debian to see if it worked there. To my surprise, the card worked again without installing the official firmware from here ( ... -8169-8110)
I reinstalled the Unifi controller and it has been working all night without a problem but...this morning it stopped responding again.

I have tried several things that I have seen on different pages (it seems that there are many problems related to network cards with Realtek chipsets) and after touching here and the Interface does not appear anywhere.

I'm not an expert in Debian but I can handle myself and follow simple steps...
I would appreciate if someone can guide me on where to start to find the problem and get the network card working (It has proven to work because if I boot from the Debian 10 Live CD, it comes back to life)

Thank you so much

Global Moderator
Global Moderator
Posts: 1876
Joined: 2014-07-20 18:12
Location: Europe
Has thanked: 38 times
Been thanked: 248 times

Re: Realtek firmware on Debian 10 Buster

#2 Post by Aki »


It could be useful to describe your general hardware/software configuration; you can use the following command (the inxi program must be installed):

Code: Select all

inxi -Fxxxz
It could be useful to have some details about your ethernet network card and used firmware; you can use the following command:

Code: Select all

lspci -vnn -d ::0200
sudo journalctl -b --no-pager --grep "firmware:"
Please use code tags to include commands and logs in a follow-up message.
⣾⠁⢠⠒⠀⣿⡁ Debian - The universal operating system

Post Reply