Scheduled Maintenance: We are aware of an issue with Google, AOL, and Yahoo services as email providers which are blocking new registrations. We are trying to fix the issue and we have several internal and external support tickets in process to resolve the issue. Please see: viewtopic.php?t=158230

 

 

 

[EDITED] firmware: failed to load iwl-debug-yoyo.bin (-2)

Share your HowTo, Documentation, Tips and Tricks. Not for support questions!.
Post Reply
Message
Author
User avatar
ticojohn
Posts: 1284
Joined: 2009-08-29 18:10
Location: Costa Rica
Has thanked: 21 times
Been thanked: 44 times

[EDITED] firmware: failed to load iwl-debug-yoyo.bin (-2)

#1 Post by ticojohn »

I don't know if others are seeing the message, but on my Intel NUC, running Bullseye amd64, I have been seeing these messages at startup for quite some time.

Code: Select all

firmware: failed to load iwl-debug-yoyo.bin (-2)
firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=966218
And it really bugged the heck out of me. So I did some research and found that this message is apparently a false message as that binary doesn't exist. Go figure. Anyway, in the Debian bug report
https://bugs.debian.org/cgi-bin/bugrepo ... bug=966218
a fix for disabling that message can be found. The fix is seen in the last entry of the bug report. It entails creating a file

Code: Select all

# nano /etc/modeprobe/d/iwlwifi.conf
and then entering the following content

Code: Select all

options iwlwifi enable_ini=N
After saving and exiting nano you will need to

Code: Select all

# update-initramfs -u
This should disable those messages from appearing during startup. Worked for me. Hope others can use this information.

EDIT: There is an error in the following code and was pointed out by @mjx

Code: Select all

# nano /etc/modeprobe/d/iwlwifi.conf
It should have been

Code: Select all

# nano /etc/modeprobe.d/iwlwifi.conf
I plead FAT FINGERS. :lol:

EDIT 2: Another user pointed another FAT FINGERS error. Should be

Code: Select all

 nano /etc/modprobe.d/iwlwifi.conf
I need to pay more attention to my typing. :mrgreen: Thanks to @Vrayden
Last edited by ticojohn on 2021-11-29 20:47, edited 4 times in total.
I am not irrational, I'm just quantum probabilistic.

d76
Posts: 15
Joined: 2020-02-15 19:17
Has thanked: 4 times
Been thanked: 3 times

Re: firmware: failed to load iwl-debug-yoyo.bin (-2)

#2 Post by d76 »

Thanks for posting this -- it worked for me.

User avatar
ticojohn
Posts: 1284
Joined: 2009-08-29 18:10
Location: Costa Rica
Has thanked: 21 times
Been thanked: 44 times

Re: firmware: failed to load iwl-debug-yoyo.bin (-2)

#3 Post by ticojohn »

d76 wrote: 2021-11-06 19:43 Thanks for posting this -- it worked for me.
Happy to be of help.
I am not irrational, I'm just quantum probabilistic.

mjx
Posts: 1
Joined: 2021-11-04 05:33

Re: firmware: failed to load iwl-debug-yoyo.bin (-2)

#4 Post by mjx »

Thank you for help.
found a slight typo in code its

Code: Select all

# nano /etc/modeprobe.d/iwlwifi.conf
and not # nano /etc/modeprobe/d/iwlwifi.conf

User avatar
ticojohn
Posts: 1284
Joined: 2009-08-29 18:10
Location: Costa Rica
Has thanked: 21 times
Been thanked: 44 times

Re: firmware: failed to load iwl-debug-yoyo.bin (-2)

#5 Post by ticojohn »

mjx wrote: 2021-11-11 17:57 Thank you for help.
found a slight typo in code its

Code: Select all

# nano /etc/modeprobe.d/iwlwifi.conf
and not # nano /etc/modeprobe/d/iwlwifi.conf
OOPS! Sorry about that. Fat fingers. The slash and dot are next to each other, so I obviously miss typed it and didn't catch my error. Glad you caught my mistake. :lol:
I am not irrational, I'm just quantum probabilistic.

User avatar
sunrat
Administrator
Administrator
Posts: 6286
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 112 times
Been thanked: 442 times

Re: firmware: failed to load iwl-debug-yoyo.bin (-2)

#6 Post by sunrat »

ticojohn wrote: 2021-11-11 19:30
mjx wrote: 2021-11-11 17:57 Thank you for help.
found a slight typo in code its

Code: Select all

# nano /etc/modeprobe.d/iwlwifi.conf
and not # nano /etc/modeprobe/d/iwlwifi.conf
OOPS! Sorry about that. Fat fingers. The slash and dot are next to each other, so I obviously miss typed it and didn't catch my error. Glad you caught my mistake. :lol:
Kindly edit your original post and put a note why it has been edited.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
ticojohn
Posts: 1284
Joined: 2009-08-29 18:10
Location: Costa Rica
Has thanked: 21 times
Been thanked: 44 times

Re: firmware: failed to load iwl-debug-yoyo.bin (-2)

#7 Post by ticojohn »

sunrat wrote: 2021-11-11 20:48
ticojohn wrote: 2021-11-11 19:30
mjx wrote: 2021-11-11 17:57 Thank you for help.
found a slight typo in code its

Code: Select all

# nano /etc/modeprobe.d/iwlwifi.conf
and not # nano /etc/modeprobe/d/iwlwifi.conf
OOPS! Sorry about that. Fat fingers. The slash and dot are next to each other, so I obviously miss typed it and didn't catch my error. Glad you caught my mistake. :lol:
Kindly edit your original post and put a note why it has been edited.
@sunrat, okay but I didn't edit my original post. My error was discovered by @mjx and he pointed it out. I guess I can edit my original post to correct my error, as I probably should do. Thanks.
I am not irrational, I'm just quantum probabilistic.

User avatar
Vrayden
Posts: 1
Joined: 2021-11-29 18:20
Been thanked: 1 time

Re: firmware: failed to load iwl-debug-yoyo.bin (-2)

#8 Post by Vrayden »

mjx wrote: 2021-11-11 17:57 Thank you for help.
found a slight typo in code its

Code: Select all

# nano /etc/modeprobe.d/iwlwifi.conf
and not # nano /etc/modeprobe/d/iwlwifi.conf
I guess it is "modprobe" and not "modeprob" :wink:

Thus:

Code: Select all

 # nano /etc/modprobe.d/iwlwifi.conf 

User avatar
ticojohn
Posts: 1284
Joined: 2009-08-29 18:10
Location: Costa Rica
Has thanked: 21 times
Been thanked: 44 times

Re: firmware: failed to load iwl-debug-yoyo.bin (-2)

#9 Post by ticojohn »

Vrayden wrote: 2021-11-29 18:44 I guess it is "modprobe" and not "modeprob" :wink:
Thanks @Vrayden . I corrected the original post.
I am not irrational, I'm just quantum probabilistic.

bedtime
Posts: 146
Joined: 2012-12-16 19:34
Has thanked: 1 time
Been thanked: 6 times

Re: [EDITED] firmware: failed to load iwl-debug-yoyo.bin (-2)

#10 Post by bedtime »

Worked perfectly for me. Thanks!

I just did a completely new Debian 11 net install, and that error didn't pop up, so I'm thinking maybe they fixed it?

Alireza
Posts: 1
Joined: 2022-07-05 17:33

Re: [EDITED] firmware: failed to load iwl-debug-yoyo.bin (-2)

#11 Post by Alireza »

hey! I did open up the nano /etc but when i insert options iwlwifi enable_ini=N and hit enter, it want me to name it but i dont know what name :( also when i refude to enter a name and press enter, it says permission denied :/ what should i do? i'd appriciate your help mate :D

User avatar
ticojohn
Posts: 1284
Joined: 2009-08-29 18:10
Location: Costa Rica
Has thanked: 21 times
Been thanked: 44 times

Re: [EDITED] firmware: failed to load iwl-debug-yoyo.bin (-2)

#12 Post by ticojohn »

Alireza wrote: 2022-07-05 17:43 hey! I did open up the nano /etc but when i insert options iwlwifi enable_ini=N and hit enter, it want me to name it but i dont know what name :( also when i refude to enter a name and press enter, it says permission denied :/ what should i do? i'd appriciate your help mate :D
As root you need to

Code: Select all

# nano /etc/modprobe.d/iwlwifi.conf
Once the file is opened you can then add the prescribed line

Code: Select all

options iwlwifi enable_ini=N
Then press
ctrl o
to save the changes
Once changes are saved press
ctrl x
to exit nano
While still logged on as user

Code: Select all

# update-initramfs -u
Log out as user, close the terminal and reboot. The changes should take effect.
Last edited by ticojohn on 2022-07-06 13:52, edited 1 time in total.
I am not irrational, I'm just quantum probabilistic.

kedaha
Posts: 3521
Joined: 2008-05-24 12:26
Has thanked: 33 times
Been thanked: 77 times

Re: [EDITED] firmware: failed to load iwl-debug-yoyo.bin (-2)

#13 Post by kedaha »

ticojohn wrote: 2022-07-05 21:18 As root you need to

Code: Select all

# nano /etc/modeprobe.d/iwlwifi.conf
Once the file is opened you can then add the prescribed line

Code: Select all

options iwlwifi enable_ini=N
[ ---]
Log out as user, close the terminal and reboot. The changes should take effect.
Indeed they should, so long as you type /etc/modprobe.d/iwlwifi.conf and not "modeprobe" as you've again posted. :wink:
Funnily enough I've often misread and mistyped modeprobe instead of modprobe myself; easily done.
Anyway, many thanks for the post; I got the firmware failure notice on my ancient Acer Aspire One netbook so I'll now be able to get rid of it.
DebianStable

Code: Select all

$ vrms

No non-free or contrib packages installed on debian!  rms would be proud.

User avatar
ticojohn
Posts: 1284
Joined: 2009-08-29 18:10
Location: Costa Rica
Has thanked: 21 times
Been thanked: 44 times

Re: [EDITED] firmware: failed to load iwl-debug-yoyo.bin (-2)

#14 Post by ticojohn »

kedaha wrote: 2022-07-06 08:41
ticojohn wrote: 2022-07-05 21:18 As root you need to

Code: Select all

# nano /etc/modeprobe.d/iwlwifi.conf
Once the file is opened you can then add the prescribed line

Code: Select all

options iwlwifi enable_ini=N
[ ---]
Log out as user, close the terminal and reboot. The changes should take effect.
Indeed they should, so long as you type /etc/modprobe.d/iwlwifi.conf and not "modeprobe" as you've again posted. :wink:
Funnily enough I've often misread and mistyped modeprobe instead of modprobe myself; easily done.
Anyway, many thanks for the post; I got the firmware failure notice on my ancient Acer Aspire One netbook so I'll now be able to get rid of it.
DARN IT! I just copied and pasted my original typo error. :mrgreen: I will edit that post. Thanks @kedaha
I am not irrational, I'm just quantum probabilistic.

lowlevell
Posts: 1
Joined: 2023-12-29 18:54
Been thanked: 1 time

Re: [EDITED] firmware: failed to load iwl-debug-yoyo.bin (-2)

#15 Post by lowlevell »

ticojohn wrote: 2021-07-28 19:10 I don't know if others are seeing the message, but on my Intel NUC, running Bullseye amd64, I have been seeing these messages at startup for quite some time.

Code: Select all

firmware: failed to load iwl-debug-yoyo.bin (-2)
firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=966218
And it really bugged the heck out of me. So I did some research and found that this message is apparently a false message as that binary doesn't exist. Go figure. Anyway, in the Debian bug report
https://bugs.debian.org/cgi-bin/bugrepo ... bug=966218
a fix for disabling that message can be found. The fix is seen in the last entry of the bug report. It entails creating a file

Code: Select all

# nano /etc/modeprobe/d/iwlwifi.conf
and then entering the following content

Code: Select all

options iwlwifi enable_ini=N
After saving and exiting nano you will need to

Code: Select all

# update-initramfs -u
This should disable those messages from appearing during startup. Worked for me. Hope others can use this information.

EDIT: There is an error in the following code and was pointed out by @mjx

Code: Select all

# nano /etc/modeprobe/d/iwlwifi.conf
It should have been

Code: Select all

# nano /etc/modeprobe.d/iwlwifi.conf
I plead FAT FINGERS. :lol:

EDIT 2: Another user pointed another FAT FINGERS error. Should be

Code: Select all

 nano /etc/modprobe.d/iwlwifi.conf
I need to pay more attention to my typing. :mrgreen: Thanks to @Vrayden
Problem when using:

Code: Select all

options iwlwifi enable_ini=N
A note when trying to apply this solution to Debian 12 Bookworm. Instead of using "N" to avoid loading the binary, it is necessary to use "0", as it currently represents "N", which would be the symbol to make it false or not.
So it would look like this:

Code: Select all

options iwlwifi enable_ini=0

lookus
Posts: 3
Joined: 2024-02-02 13:19

Caution, keep reading!

#16 Post by lookus »

for you looking a solution for this, be careful!
if you keep reading the bug report provided by op, near the end you will find a warning near the end (Message #118)
where someone (Francois Marier) warns about the effects on newer firmware (version 66 and above) refusing to load and even lockin on versions 74 and above!
and the proposed solution is to just ignore those warning by now.
you've been warned ;)

Post Reply