Scheduled Maintenance: We are aware of an issue with Google, AOL, and Yahoo services as email providers which are blocking new registrations. We are trying to fix the issue and we have several internal and external support tickets in process to resolve the issue. Please see: viewtopic.php?t=158230

 

 

 

WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

The Debian Project News and Announcements curated from official Debian news and rss feeds.

All information here is for reading only, please do not reply to threads in this forum.
Message
Author
User avatar
kalle123
Posts: 345
Joined: 2015-03-21 11:17
Location: Rhineland - Germany
Has thanked: 4 times
Been thanked: 11 times

WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#1 Post by kalle123 »

We do have messages in the German Debian forum, that there are issues with the incoming kernel 6.1.0-18
Here is the link https://debianforum.de/forum/viewtopic.php?t=189073

br KH
Last edited by kalle123 on 2024-02-10 16:34, edited 1 time in total.

User avatar
roseway
Posts: 1528
Joined: 2007-12-31 22:50
Location: Kent, UK
Has thanked: 3 times
Been thanked: 4 times

Re: Stable. Problems with the incoming update - kernel 6.1.0-18

#2 Post by roseway »

I can confirm this issue. I'm in the UK. Here's the summary of the failure of apt upgrade:
dpkg: error processing package linux-headers-6.1.0-18-amd64 (--configure):
installed linux-headers-6.1.0-18-amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-amd64:
linux-image-amd64 depends on linux-image-6.1.0-18-amd64 (= 6.1.76-1); however:
Package linux-image-6.1.0-18-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-headers-amd64:
linux-headers-amd64 depends on linux-headers-6.1.0-18-amd64 (= 6.1.76-1); however:
Package linux-headers-6.1.0-18-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
linux-image-6.1.0-18-amd64
linux-headers-6.1.0-18-amd64
linux-image-amd64
linux-headers-amd64
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)
Eric

User avatar
kalle123
Posts: 345
Joined: 2015-03-21 11:17
Location: Rhineland - Germany
Has thanked: 4 times
Been thanked: 11 times

Re: Stable. Problems with the incoming update - kernel 6.1.0-18

#3 Post by kalle123 »

Seems to be in conjunction with Nvidia ...

classicdeb
Posts: 9
Joined: 2023-09-14 07:31
Has thanked: 4 times

Re: Stable. Problems with the incoming update - kernel 6.1.0-18

#4 Post by classicdeb »

Same problem here, unfortunately (and have nvidia, as well).

User avatar
roseway
Posts: 1528
Joined: 2007-12-31 22:50
Location: Kent, UK
Has thanked: 3 times
Been thanked: 4 times

Re: Stable. Problems with the incoming update - kernel 6.1.0-18

#5 Post by roseway »

I have nVidia too, but I think the failure to build the nVidia module is a consequence of the linux-headers failure, not the cause of the problem.
Eric

User avatar
kalle123
Posts: 345
Joined: 2015-03-21 11:17
Location: Rhineland - Germany
Has thanked: 4 times
Been thanked: 11 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18

#6 Post by kalle123 »

I changed the subject of this thread into WARNING.

User avatar
sylvain_48
Posts: 21
Joined: 2023-11-10 19:05

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18

#7 Post by sylvain_48 »

In the /var/lib/dkms/nvidia-tesla-470/470.223.02/build/make.log file:

ERROR: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_lock'
ERROR: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_unlock'

User avatar
sunrat
Administrator
Administrator
Posts: 6286
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 112 times
Been thanked: 442 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#8 Post by sunrat »

Same issue here. Probably need to wait for an update for the nvidia driver which seems incompatible. For now, if you have upgraded to Debian 12.5, you can purge the kernel 6.1.0-18 and continue to use the 6.1.0-17 kernel if you use the nvidia driver. Do not run autoremove!

Code: Select all

apt purge linux-image-amd64 linux-headers-amd64 linux-image-6.1.0-18-amd64 linux-headers-6.1.0-18-amd64
Reinstall linux-image-amd64 and linux-headers-amd64 when a fix is available.

Or you can just boot 6.1.0-17 kernel from GRUB until the fix is in the repo. I only did the purge as it was blocking install of other packages.

I edited the title to show the issue is with nvidia driver.

A fix is on the way. See viewtopic.php?p=792730#p792730
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
MikeLieberman
Posts: 159
Joined: 2013-01-29 17:26
Location: General Santos City, Philippines
Has thanked: 17 times
Been thanked: 2 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#9 Post by MikeLieberman »

Same problem here: (I have purged 6.1.0-18- and am staying with 6.1.0-17-amd.

I have an NVidia video card.

env NV_VERBOSE=1 make -j28 modules KERNEL_UNAME=6.1.0-18-amd64.........(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-18-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-tesla-470/470.223.02/build/make.log for more information.
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information.
dkms: autoinstall for kernel: 6.1.0-18-amd64 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 11
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-6.1.0-18-amd64.postinst line 11.
dpkg: error processing package linux-headers-6.1.0-18-amd64 (--configure):
installed linux-headers-6.1.0-18-amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-amd64:
linux-image-amd64 depends on linux-image-6.1.0-18-amd64 (= 6.1.76-1); however:
Package linux-image-6.1.0-18-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-headers-amd64:
linux-headers-amd64 depends on linux-headers-6.1.0-18-amd64 (= 6.1.76-1); however:
Package linux-headers-6.1.0-18-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
linux-image-6.1.0-18-amd64
linux-headers-6.1.0-18-amd64
linux-image-amd64
linux-headers-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

User avatar
otello.an
Posts: 14
Joined: 2022-01-28 13:19
Location: Italy
Been thanked: 2 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#10 Post by otello.an »

Same problem here (Italy)! Please fix ASAP!

Texlee
Posts: 47
Joined: 2024-01-05 15:10
Has thanked: 4 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#11 Post by Texlee »

Same problem, I also have an nvidia graphics card. Fortunately it didn't install the .18 kernel, I still have the .17

Texlee
Posts: 47
Joined: 2024-01-05 15:10
Has thanked: 4 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#12 Post by Texlee »

sunrat wrote: 2024-02-10 22:38 Do not run autoremove!
Why not?

sunrat wrote: 2024-02-10 22:38

Code: Select all

apt purge linux-image-amd64 linux-headers-amd64 linux-image-6.1.0-18-amd64 linux-headers-6.1.0-18-amd64
It didn't install me the .18 kernel but I still have the .17 one. Don't I risk to have problems if I purge linux-image-amd64 and linux-headers-amd64 ? Aren't they the actual installed on my system?
Thanks

reformedhatter
Posts: 3
Joined: 2024-01-30 10:33

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#13 Post by reformedhatter »

Yes, I updated before seeing any warning messages about the update. Unable to log back in afterwards. Just a black screen with white writing on it. Thankfully, I had only backed up with rescuezilla the other day so did a restore, uninstalled the nvidia drivers and updated. All is well with the world again.

User avatar
Chaussettes
Posts: 46
Joined: 2022-09-29 03:45
Has thanked: 7 times
Been thanked: 20 times
Contact:

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#14 Post by Chaussettes »

Does this affect legacy NVIDIA 470 drivers or all of the NVIDIA driver versions? I have a card that uses the legacy 470 drivers and not the current 525.
Creating art on deviantArt - https://www.deviantart.com/chaussettes99

User avatar
otello.an
Posts: 14
Joined: 2022-01-28 13:19
Location: Italy
Been thanked: 2 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#15 Post by otello.an »

I just saw that the new version of the nvidia-graphics-drivers 525.147.05-6~deb12u1 (source amd64) have just been included in the proposed-updates [I don't know how long it takes them to go from proposed to stable] Well! But...

Can anyone tell me what to do regarding the 470 ones?

P.S. I update my post: now (13/02) the new 470 drivers have also been added to the proposed updates.

Thanks

User avatar
None1975
df -h | participant
df -h | participant
Posts: 1380
Joined: 2015-11-29 18:23
Location: Russia, Kaliningrad
Has thanked: 44 times
Been thanked: 64 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#16 Post by None1975 »

Chaussettes wrote: 2024-02-12 19:52 Does this affect legacy NVIDIA 470 drivers or all of the NVIDIA driver versions? I have a card that uses the legacy 470 drivers and not the current 525.
Yes, this also affect legacy NVIDIA 470 drivers.
OS: Debian 12.4 Bookworm / DE: Enlightenment
Debian Wiki | DontBreakDebian, My config files on github

User avatar
otello.an
Posts: 14
Joined: 2022-01-28 13:19
Location: Italy
Been thanked: 2 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#17 Post by otello.an »

Please, could someone tell me (for future help for another similar bug) where it is possible to manual download the new versions of the future drivers (470 new and 525 new for debian) complete with their dependencies to be able to install them locally without going through the proposed updates?

Thank you!

WyRd_MonSteroids
Posts: 2
Joined: 2024-02-12 08:58
Has thanked: 1 time

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#18 Post by WyRd_MonSteroids »

Does anyone know if this has been fixed?

User avatar
Organic_Marble
Posts: 14
Joined: 2023-05-16 17:03
Has thanked: 14 times
Been thanked: 3 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#19 Post by Organic_Marble »

A patched driver has been placed in the proposed-updates repository. It fixed the problem for me.

User avatar
kalle123
Posts: 345
Joined: 2015-03-21 11:17
Location: Rhineland - Germany
Has thanked: 4 times
Been thanked: 11 times

Re: WARNING!. Problems with the incoming update - kernel 6.1.0-18 & nvidia driver

#20 Post by kalle123 »

You have to add this to sources.list

Code: Select all

# proposed updates for the next point release
  deb http://ftp.us.debian.org/debian bookworm-proposed-updates main contrib non-free non-free-firmware
cu KH

Post Reply