Scheduled Maintenance: We are aware of an issue with Google, AOL, and Yahoo services as email providers which are blocking new registrations. We are trying to fix the issue and we have several internal and external support tickets in process to resolve the issue. Please see: viewtopic.php?t=158230

 

 

 

More about brightness buttons not working (DELL Vostro 360)

Need help with peripherals or devices?
Post Reply
Message
Author
leondante
Posts: 9
Joined: 2018-11-12 19:43

More about brightness buttons not working (DELL Vostro 360)

#1 Post by leondante »

Hello from a Debian noob.

After spending around 10 hours trying different solutions and learning a lot about brightness things and graphic drivers, I decided to open even another thread about this to see if someone can help me because I'm on a dead end. This all-in-one PC has just four buttons at one side for volume and brightness. Volume button aren't working at all, and brightness just shows the graphic going up and down, with no effect at all. I'm in a place very dark at night and very bright at day and I use this PC a lot, so is a real issue to me because it gives me some headache by the minute along the day not to be able to change the brightness comfortably.

I'm using Debian 12, with MATE.

Changing things inside /sys/class/backlight/acpi_video0 does not a damn thing, and there's only THAT folder, so I have two graphic chips but no one is linked to that folder there because is not working at all.

I changed the drivers, having some bad issues, to the nvidia-legacy-390xx, but it depends on an obsolete xserver-xorg-core that kills keyboard and mouse if I change it. Even changing it, the problem continues.

I have results using

Code: Select all

xrandr --output eDP-1 --brightness .4
and so, but the solutions I find about binding the buttons to that command are using the /sys/class/blablabla... path that does nothing, so they are useless. This command works for seconds and comes back to full kill-my-eyes brightness like 5 seconds later. Closing redshift stopped it from coming back to the previous brightness, and that's an issue too because I also use redshift to help a bit my already tired eyesight.

Thanks a lot beforehand for any practical help or trying you can give me.

This is my graphic stuff:

Code: Select all

root@Vostro360:/home/myuser/Programas# lspci -k | grep -EA3 'VGA|3D|Display'

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
	Subsystem: Dell 2nd Generation Core Processor Family Integrated Graphics Controller
	Kernel driver in use: i915
	Kernel modules: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1)
	Subsystem: Dell GF108M [GeForce GT 525M]
	Kernel driver in use: nvidia
	Kernel modules: nvidia

Code: Select all

root@Vostro360:/home/myuser/Programas# xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080     59.98*+  59.96    59.93  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
VGA-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)

User avatar
ruwolf
Posts: 640
Joined: 2008-02-18 05:04
Location: Banovce nad Bebravou
Has thanked: 40 times
Been thanked: 29 times

Re: More about brightness buttons not working (DELL Vostro 360)

#2 Post by ruwolf »

Hello from old Debian semi-noob. :)

Do you have installed necessary firmware for sound?
And which GPU do you want to use, dedicated Nvidia?

Post Reply