Package dependencies

If none of the more specific forums is the right place to ask
Post Reply
Message
Author
ukstone
Posts: 3
Joined: 2019-01-05 13:38

Package dependencies

#1 Post by ukstone »

Linux roblaptop 5.2.0-3-amd64 #1 SMP Debian 5.2.17-1 (2019-09-26) x86_64 GNU/Linux

Whilst doing a safe-upgrade yesterday, 77 packages were left behind.
Running dist-upgrade revealed the following:-

The following packages have unmet dependencies:
libldb2 : Breaks: libldb1 (< 2:2~) but 2:1.5.1+really1.4.7-1 is installed
python-tdb : Depends: libtdb1 (= 1.3.18-2) but 1.4.2-2 is to be installed
python-vte : Depends: libvte-common (= 1:0.28.2-5) but 1:0.28.2-6 is to be installed
python-samba : Depends: samba-libs (= 2:4.9.13+dfsg-1) but 2:4.11.1+dfsg-2 is to be installed
fwupdate : Breaks: fwupdate-signed which is a virtual package, provided by:
- fwupdate-amd64-signed (12+5), but 12+5 is installed

libpolkit-backend-1-0 : Depends: libpolkit-gobject-1-0 (= 0.105-25) but 0.105-26 is to be installed
fwupd : Conflicts: fwupdate-amd64-signed but 12+5 is installed
fwupdate-amd64-signed : Depends: fwupdate (= 12-5) but 12-7 is to be installed
libgtk2-perl : Depends: perlapi-5.28.1 which is a virtual package, provided by:
- perl-base (5.28.1-6), but 5.30.0-9 is to be installed

The following actions will resolve these dependencies:

Remove the following packages:
1) fwupdate-amd64-signed [12+5 (now)]
2) libgtk2-perl [2:1.24993-1 (now)]
3) libldb1 [2:1.5.1+really1.4.7-1 (now)]
4) libpolkit-backend-1-0 [0.105-25 (now)]
5) python-ldb [2:1.5.1+really1.4.7-1 (now)]
6) python-samba [2:4.9.13+dfsg-1 (now)]
7) python-tdb [1.3.18-2 (now)]
8) python-vte [1:0.28.2-5+b3 (now)]

Leave the following dependencies unresolved:
9) gdebi recommends libgtk2-perl


Does anybody "know" when these unmet dependencies will be fixed.

I am concerned that if I do run a dist-upgrade, my laptop will hang or not boot or have a problem.
I rely on my laptop working.

TIA,
Robert

Deb-fan
Posts: 1042
Joined: 2012-08-14 12:27

Re: Package dependencies

#2 Post by Deb-fan »

You really need to provide some more general info. This is Stretch (fresh or upgraded in place to Buster ?) These are packages you downloaded and installed with gdebi or etc ? From where ... are you using ppa's for example ? Could go ahead and post your sources.list file.

Other random thoughts would include running the following, NOTE the -s switch for simulated, means it simulates, doesn't actually do anything "sudo apt install -f -s". Also people have long advised trying aptitude, as they say it offers more suggestions to resolve package issues. I've resisted learning or using it much as I prefer apt, shrugs. The package situation you're finding yourself in clearly indicates you're doing things non-standard and likely aren't familiar enough with to do correctly at this time. Could and may want to bone up on your Debian gnu/Linux package management skillz. Anyway good luck ...
Most powerful FREE tech-support tool on the planet * HERE. *

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3760
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 3 times
Been thanked: 12 times

Re: Package dependencies

#3 Post by sunrat »

Looks like testing or unstable. Breakages happen sometimes, you need to be careful when you upgrade mainly by aborting and postponing if a lot of packages are flagged to be removed. You might be lucky and be able to get back to normal at a later time or day (sometimes a week or more). Or you might be FUBAR.
You can try aptitude, it does resolving better than plain apt. May work or may not. If needed packages are not in the repo, it won't help.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

Deb-fan
Posts: 1042
Joined: 2012-08-14 12:27

Re: Package dependencies

#4 Post by Deb-fan »

FRANKENDEB !!!! Ahhhhhh, ya see OP, you're the reason we can't have nice things ! :(

Messing around, almost certainly someone with the know how and experience will have little problem unborking such an install. However, doesn't seem you/OP are such a person. Ran mixed systems for quite awhile w/o problems. Ran Sid for years ... same deal. In fact based on my own experience and that of more experienced and sometimes knowledgeable nixers, found unstable to be more stable than testing. Fixes/updates come down the pipe into the repo's more quickly than into testing.

However have also pretty much always employed the KISS principle, "keep it simple stupe" etc. Setting things up in a very minimal fashion, using Openbox vs latest Kde etc etc. Never had issues with Sid, even disregarding common and best practices often and didn't get hit with major borkage. If this is unstable OP, also install the package apt-listbugs. Such will warn you of reported bugs in packages during the upgrade process and let someone choose to address it before installing. Also if unstable sometimes people did have to resort to putting packages on hold until fixes for whatever known issues came down the pipe. Such stuff usually resolved itself within a few days and they could proceed to upgrade the packages involved.

Anyway if this is some Frankendeb OS or Debian unstable ... The issues you're having here make it plain you aren't quite ready for them but surely can learn to be and it's not the end of the world to bork, bork and bork yaself some more if that's your preferred method of learning, shrugs. :D
Most powerful FREE tech-support tool on the planet * HERE. *

Deb-fan
Posts: 1042
Joined: 2012-08-14 12:27

Re: Package dependencies

#5 Post by Deb-fan »

Something helpful :D ...

Show folks your sources.list and /etc/apt/preferences files OP ? Well mostly just the sources.list is the place to start. Definitely get the feeling with whatever was done here apt-pinning was never learned about nor utilized. Blahblahblah.
Most powerful FREE tech-support tool on the planet * HERE. *

Post Reply