[solved] installing wxpython in debian10

Programming languages, Coding, executables, and scripting.
Post Reply
Posts: 184
Joined: 2017-03-26 10:14

[solved] installing wxpython in debian10

#1 Post by peer »

I created succesfully little programs with python 3.7 and tkinter
Now I want to try wxpython instead of tktintr.
On "https://wiki.wxpython.org/How%20to%20install%20wxPython" I noticed that wxpython is in the repository of debian 10. So I installed python-wxgtk4.0.

But when I wanted to import wxpython with the statement "import wx" I got the error "No module named 'wx'"
I did search for an answer on this forum with no result.
I googled the problem and found several solutions but none of them did help me.
I also read somewhere that wxpython does not work with python 3 at all and I should instead install wxpython-phoenix.

How can I properly install wxpython on debian 10 (kde)???

I found a working solution on: "http://test.wxpython.org/pages/downloads/index.html"
In the terminal I gave the command: "sudo pip3 install -U wxPython".
Then I had install "libgtk-3.dev" because I got a n error that showed that gtk-files were missing
After that I repeated the pip3 command and the installation completed (took a long time) sucessfully

Post Reply