Scheduled Maintenance: We are aware of an issue with Google, AOL, and Yahoo services as email providers which are blocking new registrations. We are trying to fix the issue and we have several internal and external support tickets in process to resolve the issue. Please see: viewtopic.php?t=158230

 

 

 

How to enable root password?

Linux Kernel, Network, and Services configuration.
Post Reply
Message
Author
anto
Posts: 12
Joined: 2008-07-02 21:07
Location: Vienna, Austria

How to enable root password?

#1 Post by anto »

Hello Everybody,

Due to Debian CD installation does not recognise my Logitech wireless USB keyboard, I did the installation using debootstrap via the live CD. I am not sure which part that I missed, but since then the su command on the user's terminal does not ask for password for root. And from the GUI, I can launch any administrative functions which do not ask for root password but I got a message saying "Granted permissions without asking for password".

There must be something very simple that I missed, but I could not find it. Searching the internet mostly find the answers to do the other way around, i.e. disabling root password. Could anybody give me some hints on what to change on my configuration?

I am running AMD64 version of Debian squeeze.

Kind regards,

Anto

User avatar
aspnair
Posts: 1247
Joined: 2009-06-18 12:27
Location: Twitter: @anand_sivaram

Re: How to enable root password?

#2 Post by aspnair »

Your root may not have any password. Set it explicity, after loggging in as root,
use "passwd" command to set the root password.
Compressed Air Energy Storage, Entropy and Efficiency
http://saurorja.org/2012/06/18/compress ... fficiency/

anto
Posts: 12
Joined: 2008-07-02 21:07
Location: Vienna, Austria

Re: How to enable root password?

#3 Post by anto »

aspnair wrote:Your root may not have any password. Set it explicity, after loggging in as root,
use "passwd" command to set the root password.
Thanks for the hint, but I tried that. It does not even ask for the new password prompt as below

Code: Select all

root@localhost:~# passwd
passwd: password updated successfully
root@localhost:~# 

barriehie

Re: How to enable root password?

#4 Post by barriehie »

Try the command, after logging in as root, like this:

Code: Select all

passwd root
Barrie

anto
Posts: 12
Joined: 2008-07-02 21:07
Location: Vienna, Austria

Re: How to enable root password?

#5 Post by anto »

barriehie wrote:Try the command, after logging in as root, like this:

Code: Select all

passwd root
Barrie
Thanks Barrie. Believe me, I tried that as well.

Code: Select all

root@localhost:~# passwd root
passwd: password updated successfully
root@localhost:~# 

barriehie

Re: How to enable root password?

#6 Post by barriehie »

K, try then deleting the passwd and reinstalling it:

Code: Select all

passwd -d root
then

Code: Select all

passwd root

barriehie

Re: How to enable root password?

#7 Post by barriehie »

Here's an idea too,
From your login:

Code: Select all

su -c 'passwd root'

anto
Posts: 12
Joined: 2008-07-02 21:07
Location: Vienna, Austria

Re: How to enable root password?

#8 Post by anto »

The same thing.

Code: Select all

root@localhost:~# passwd -d root
passwd: password expiry information changed.
root@localhost:~# passwd root
passwd: password updated successfully
root@localhost:~# 
root@localhost:~# su -c 'passwd root'
passwd: password updated successfully
root@localhost:~# 
There seems to be no password authentication enabled. I created a couple user accounts and the same thing happen to them.

barriehie

Re: How to enable root password?

#9 Post by barriehie »

What does this output?

Code: Select all

aptitude search libpam-runtime
Do you have an /etc/pam.d directory?

anto
Posts: 12
Joined: 2008-07-02 21:07
Location: Vienna, Austria

Re: How to enable root password?

#10 Post by anto »

Thanks a lot Barrie for the hint.

I have PAM installed but for what ever reason I set the authentication to use "GNOME Keyring Daemon" as below:

Code: Select all

PAM profiles to enable:
[ ] Unix authentication
[*] GNOME Keyring Daemon - Login keyring management
[ ] ConsoleKit Session Management
Everything seems to be normal after I changed that to "Unix authentication".

barriehie

Re: How to enable root password?

#11 Post by barriehie »

anto wrote:Thanks a lot Barrie for the hint.

I have PAM installed but for what ever reason I set the authentication to use "GNOME Keyring Daemon" as below:

Code: Select all

PAM profiles to enable:
[ ] Unix authentication
[*] GNOME Keyring Daemon - Login keyring management
[ ] ConsoleKit Session Management
Everything seems to be normal after I changed that to "Unix authentication".
Glad you got it! Sometimes the shot in the dark works... :) So this is now solved???

anto
Posts: 12
Joined: 2008-07-02 21:07
Location: Vienna, Austria

Re: How to enable root password?

#12 Post by anto »

barriehie wrote: :) So this is now solved???
Yes, Barrie. It is now solved. Thanks again for the hint.

barriehie

Re: How to enable root password?

#13 Post by barriehie »

anto wrote:
barriehie wrote: :) So this is now solved???
Yes, Barrie. It is now solved. Thanks again for the hint.
I just tripped over it... :)

Post Reply